Glacier

Installing Glacier

Add nemo:devel:ux repository:  ssu ar http://repo.merproject.org/obs/nemo:/devel:/ux/mer-core_armv7hl_devel/ nemo-devel-ux

After this issue: pkcon refresh

Download Glacier desktop and theme: pkcon install nemo-theme-glacier lipstick-glacier-home-qt5

Edit file: vi /usr/share/lipstick-glacier-home-qt5/nemovars.conf
Change GLACIER_NATIVEORIENTATION=1 to GLACIER_NATIVEORIENTATION=2

Then we need to open the file: vi /usr/share/themes/glacier/index.theme
And change X-inherits=Darko to X-inherits=jolla-ambient

Save and quit.
Then reboot with the command: reboot

Now you should see the Glacier desktop.

7 thoughts on “Glacier

  1. Hi, shoult it be
    ssu ar nemo-devel-ux http://repo.merproject.org/obs/nemo:/devel:/ux/mer-core_armv7hl_devel/ # i.e. repo name before the URL?

    Command pkcon install nemo-theme-glacier lipstick-glacier-home-qt5 throws error Command failed: This tool could not find any available package: could not find nemo-theme-glacier

    Is there something I should do before? My device is not registered in any way, does this matter? My device model is UNKNOWN (to ssu, but it is Rpi2).

    Now using http://images.devaamo.fi/sfa/raspberrypi/sfos-rpi2-1.1.2.16.img.xz

    Last time (with sfos-raspberrypi2-1.1.2.15.img.xz) I stumbled here also, and then tried to download and install packages manually, but eventually the dependencies were impossible to solve because of conflicting packages so I quit.

    Like

    1. Hi, shoult it be
      ssu ar nemo-devel-ux http://repo.merproject.org/obs/nemo:/devel:/ux/mer-core_armv7hl_devel/ # i.e. repo name before the URL?

      Command pkcon install nemo-theme-glacier lipstick-glacier-home-qt5 throws error Command failed: This tool could not find any available package: could not find nemo-theme-glacier

      Is there something I should do before? My device is not registered in any way, does this matter? My device model is UNKNOWN (to ssu, but it is Rpi2).

      Now using http://images.devaamo.fi/sfa/raspberrypi/sfos-rpi2-1.1.2.16.img.xz

      Last time (with sfos-raspberrypi2-1.1.2.15.img.xz) I stumbled here also, and then tried to download and install packages manually, but eventually the dependencies were impossible to solve because of conflicting packages so I quit.

      Like

  2. Just a quick note: gracier runs and terminal starts but is upside-down, clock/calculator/media do not start, and I get an empty lightgrey/white box in the upper left corner of the screen (size a bit less that 1/4 of the whole screen) without any clear reason (or is this some of the app I tried to run)? Need to look at pkcon if I can update the packages.

    Really looking forward to run sailfish in my Raspi2! Thanks for the effort!

    I’ll get another SD card so I can more easily test new images when those come available.

    Like

    1. Hi Paavo! We are fully aware that apps are orientated in the wrong way + flipped.
      This build is new, and runs better than the old one.

      Locusf might have a solution for it. Anyway, stay tuned for newer builds!

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s